Product Search Service Outage
Resolved·Degraded performance

All product search functionality has been fully restored.

Tue, Nov 4, 2025, 10:32 AM
(1 month ago)
·
Affected components
Folio
Updates

Resolved

All product search functionality has been fully restored.

Tue, Nov 4, 2025, 10:32 AM

Monitoring

We're monitoring the resolution of an issue.

Tue, Nov 4, 2025, 12:09 AM(10 hours earlier)